Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-640

Update CFITSIO to version 3.47 (aka 3470)

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None

      Description

      In some of the work as part of DM-20864, some likely issues have been identified with how our code and CFITSIO work together in the serialization, particularly with metadata (likely long keywords). This RFC would definitely trigger those issues on implementation, but the we would need to resolve those issues in any case to use a conda-forge provider CFITSIO.

        Attachments

          Issue Links

            Activity

            tjenness Tim Jenness added a comment -

            I'm in favor of this. We have previously agreed an update of cfitsio that was not done (RFC-105).

            bvan Brian Van Klaveren added a comment -

            DM-21991 has been created from issues seen with cfitsio 3.47.

            Parejkoj John Parejko added a comment -

            As the filer of RFC-105 (who then abandoned it due to other build/compatibility issues), I strongly support this. I'd warn you that you may encounter even more issues as you try to integrate a newer cfitsio.

            rhl Robert Lupton added a comment -

            I'm fine with updating cfitsio – good luck! --, but I don't think that it resolves our concerns about

            metadata (likely long keywords)

            as the filling cfitsio's behaviour isn't the same as obeying the standard. I strongly suspect that cfitsio will use HIERARCH which is (regrettably) not in the FITS standard.

            bvan Brian Van Klaveren added a comment -

            I did some digging in DM-21991. The issue is that the first 8 characters of a fits key name were forced to be uppercase before 3380. In 3380, it's the whole keyname. This breaks some APIs since the case is destroyed in serialization for some things, at least part of ExposureInfo for sure in afw.

            This is also relevant:
            https://community.lsst.org/t/fits-and-lowercase-header-keys/1184

            tjenness Tim Jenness added a comment -

            I am more than happy for you to adopt this RFC. All the issues do need to be fixed regardless since we are not going to be able to use this old version of cfitisio forever.


              People

              • Assignee:
                bvan Brian Van Klaveren
                Reporter:
                bvan Brian Van Klaveren
                Watchers:
                Brian Van Klaveren, John Parejko, John Swinbank, Robert Lupton, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Planned End:

                  Summary Panel