Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-75

self-merge policy for lsstsw/etc/repos.yaml

    XMLWordPrintable

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None
    • Location:
      ISSUE

      Description

      I propose that a special-snowflake self-merge policy be adopted for https://github.com/lsst/lsstsw/blob/master/etc/repos.yaml on that basis that:

      • this file is CI configuration data in a simple format; there is no logic for a reviewer to evaluate
      • modifications being merged into this file are in the critical path for many development activities
      • a lint script (DM-3151) is run automatically by travis CI on all pushes & PRs to this repository

      Proposed policy:

      A developer may merge change(s) to the repos.yaml file in the lsstsw repo without formal code review if a github PR has been opened for the change(s) and travis CI has returned a success status for that PR.

      (see attached images of github's CI status flags)

        Attachments

          Issue Links

            Activity

            jhoblitt Joshua Hoblitt added a comment -

            John Swinbank I can set the CI status check mark and send the hipchat notification from jenkins instead of travis, it will look exactly the same except for where you get send if you click on the status link. Since the CI build is triggered automatically on push the user doesn't really need to know details about the infrastructure plumbing in advance. Travis was just easier to setup since there isn't a python env currently on our build slaves but this isn't very difficult to change.

            swinbank John Swinbank added a comment -

            Hey Joshua Hoblitt – I have no problem with the choice of technology. Whatever you think works best and is least overhead for you is fine.

            I'm just a little worried about the proliferation of technologies and terminologies. If this case really is as simple as "don't hit merge until you see a green tick", that's fine. If there's any further bleed over of terminology or UI from Travis, though, I'm just asking that it should be really clearly documented somewhere obvious what it is and why.

            My concern here is just that not everybody is active on HipChat, and I know from talking to folks offline that there's some confusion about the new technologies (Discourse, Jenkins, Travis, etc). being introduced or talked about and how they relate to each other and to existing systems. Don't get me wrong, the new stuff is great and I love it – but simply being clear about what SQuaRE is supporting and what it does would help.

            frossie Frossie Economou added a comment -

            John Swinbank Point completely taken that we need some decent developer documentation explaining all this stuff. Real Soon Now (tm).

            Joshua Hoblitt I have confirmed with John that he did not intend his comment as an objection to the RFC.

            tjenness Tim Jenness added a comment -

            I'm going to say this is IMPLEMENTED despite DM-4318 still being open. That ticket is open because the page where the policy is documented needs to be reworked slightly. Regardless, the developer guide does not document the self merge policy. See https://developer.lsst.io/build-ci/new_package.html


              People

              Assignee:
              jhoblitt Joshua Hoblitt
              Reporter:
              jhoblitt Joshua Hoblitt
              Watchers:
              Frossie Economou, John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Planned End: