Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-76

update activemq-cpp/apr/lua/mysq packages to el6/epel-6 versions

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None
    • Location:
      ISSUE

      Description

      The following list of thirdparty packages are both present in el6 core repos or epel-6 and have a version lower than what is available from those sources. As el6 is currently set as the "low bar", I would like to update all of these eups packages to the el6 level.

      activemq-cpp-devel 3.5.0 -> 3.8.2
      apr 1.3.3 -> 1.3.9
      apr-util 1.3.4 -> 1.3.9
      lua-expat 1.1 -> 1.3.0
      lua-socket 2.0.2 -> 3.0
      mysql 5.1.72 -> 5.1.73
      mysql-proxy 0.8.2 -> 0.8.5
      

        Attachments

          Issue Links

            Activity

            Hide
            ktl Kian-Tat Lim added a comment -

            No objection as long as things don't break

            Show
            ktl Kian-Tat Lim added a comment - No objection as long as things don't break
            Hide
            rhl Robert Lupton added a comment -

            I looked at the new wcslib then stopped as I found an alternative. I support upgrading it, but it scares me a bit as there are quite a few changes.

            Show
            rhl Robert Lupton added a comment - I looked at the new wcslib then stopped as I found an alternative. I support upgrading it, but it scares me a bit as there are quite a few changes.
            Hide
            tjenness Tim Jenness added a comment -

            I see that activemqcpp and wcslib have been updated and MySQL is no longer relevant because we have switched to MariaDB. I think that means we need tickets to be created for the upgrade of the apr and lua packages.

            Show
            tjenness Tim Jenness added a comment - I see that activemqcpp and wcslib have been updated and MySQL is no longer relevant because we have switched to MariaDB. I think that means we need tickets to be created for the upgrade of the apr and lua packages.
            Hide
            tjenness Tim Jenness added a comment -

            luasocket and luaexpat were only used by luaxmlrpc and that package is no longer used in the stack as Qserv stopped using it in DM-4348.

            Show
            tjenness Tim Jenness added a comment - luasocket and luaexpat were only used by luaxmlrpc and that package is no longer used in the stack as Qserv stopped using it in DM-4348 .
            Hide
            tjenness Tim Jenness added a comment -

            I think the only thing keeping this RFC open is the move of the lua packages to legacy status (DM-5140). It seems that that's almost a trivial amount of work (3 packages being moved from lsst to lsst-dm with associated edit to repos.yaml). Are we ever going to get round to it or shall we just say this RFC is completed and remove DM-5140 from blocking its closing?

            Show
            tjenness Tim Jenness added a comment - I think the only thing keeping this RFC open is the move of the lua packages to legacy status ( DM-5140 ). It seems that that's almost a trivial amount of work (3 packages being moved from lsst to lsst-dm with associated edit to repos.yaml). Are we ever going to get round to it or shall we just say this RFC is completed and remove DM-5140 from blocking its closing?

              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Paul Price, Robert Lupton, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Planned End:

                  Summary Panel