Your suggestion sounds like a big improvement. Nonetheless, I'll ask for even more: I think "ingestImages.py" is too ambiguous: it sounds as if images are being ingested to a database, or at least added to an existing collection of some kind. So I will request a clearer and less ambiguous name.
I suggest "makeRepoFromImages". It is rather long, but quite clear and unambiguous. If the operation is sufficiently rare then the long name will not hurt, and auto-completion will work once one types "makeRepo".
"repoFromImages" might do, but I miss the verb. I do not like "imagesToRepo" because it sounds as if it might be adding images to an existing repo.