Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-849

Rename the {Name}ID field in indexed SAL topics to salIndex

    XMLWordPrintable

Details

    • RFC
    • Status: Implemented
    • Resolution: Done
    • T&S
    • None
    • This ticket

    Description

      SAL topics for indexed components have a field named {Name}ID (e.g. MTHexapodID or ScriptID). I propose to rename this to salIndex (was private_index; changed after 2022-05-03 CAP meeting) to simplify usage and make topics more uniform. It is a nuisance to have to compute the name of the field.

      I think this only affects Python code (and ts_sal internally). I don't know of any indexed non-Python CSCs. The Java Camera CSCs, ATMCS, etc are not indexed.

      Also note that most code that deals with a specific index of a SAL component never sees this field. ts_salobj or ts_sal does the right thing when you specify an index.

      Code that will need updating includes:

      • Chronograf dashboards that filter on a specified SAL index.
      • Some LOVE code, such as the ScriptQueue display.
      • ts_scriptqueue, which uses this field to command a specific script.
      • Possibly some Jupyter notebooks.

      I have converted both ts_salobj and ts_scriptqueue and it was trivial. I expect the Chronograf dashboards to also be easy and am offering to do the work.

      Attachments

        Issue Links

          Activity

            rowen Russell Owen added a comment -

            This was provisionally accepted by CAP 2022-05-3. The big question is whether INRIA is willing to make this change for LOVE.

            rowen Russell Owen added a comment - This was provisionally accepted by CAP 2022-05-3. The big question is whether INRIA is willing to make this change for LOVE.

            Hi Russell, I've checked if we were using that variable and we do in some files across the LOVE-repositories, particullary on the LOVE-frontend and LOVE-producer. There is not much work to do though, so we are good if you need to do the change.

            sebastian.aranda Sebastian Aranda [X] (Inactive) added a comment - Hi Russell, I've checked if we were using that variable and we do in some files across the LOVE-repositories, particullary on the LOVE-frontend and LOVE-producer. There is not much work to do though, so we are good if you need to do the change.
            rowen Russell Owen added a comment -

            Adopted as stated

            rowen Russell Owen added a comment - Adopted as stated
            rowen Russell Owen added a comment - - edited

            Note that there are a few existing public fields named "salIndex" in the ScriptQueue SAL component. I will rename those to "scriptSalIndex". It makes for more work for INRIA but I think it improves the API slightly. (Though this is also the reason I originally wanted private_index – that prefix assured there could be no collisions).

            rowen Russell Owen added a comment - - edited Note that there are a few existing public fields named "salIndex" in the ScriptQueue SAL component. I will rename those to "scriptSalIndex". It makes for more work for INRIA but I think it improves the API slightly. (Though this is also the reason I originally wanted private_index – that prefix assured there could be no collisions).

            People

              rowen Russell Owen
              rowen Russell Owen
              Russell Owen, Sebastian Aranda [X] (Inactive), Wouter van Reeven
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                Planned End:

                Jenkins

                  No builds found.