Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-972

Rename prompt_prototype to prompt_processing

    XMLWordPrintable

Details

    Description

      When it was first created, the Prompt Processing service at https://github.com/lsst-dm/prompt_prototype really was intended as a prototype, with the assumption that it would be replaced wholesale. Instead, we've been iteratively improving it, and while it's not yet feature-complete, it's clear that we won't be creating a second service from scratch.

      In the meantime, however, we have any number of components with the "prototype" or "proto" name. Aside from the obvious confusion of using a "prototype" in Operations, it can be hard to keep track of which components are called "prototype" and which are "processing".

      I propose that we remove all references to a prototype, and consistently use the name "Prompt Processing" or variants thereof. This would involve the following changes:

      • Rename https://github.com/lsst-dm/prompt_prototype to prompt_processing, following DMTN-027.
      • Rename the Jira prompt_prototype component to prompt_processing
      • Rename our build containers from prompt-proto-base and prompt-proto-service to prompt-base and prompt-service.
      • Rename (in practice, copy and delete?) our Vault secrets from usdf-prompt-processing[-dev]/prompt-proto-service-<instrument> (which uses both naming conventions!) to usdf-prompt-processing[-dev]/prompt-service-<instrument>.
      • Rename our Phalanx apps from prompt-proto-service[-<instrument>] to prompt-service[-<instrument>]. I think we don't need to specifically update the application docs on https://phalanx.lsst.io/; all references to "proto" are auto-generated.
      • Rename (in practice, copy and delete?) our Argo apps and Kubernetes namespaces from prompt-proto-service-<instrument> to prompt-service-<instrument>.
      • Update the dispatch URLs used by next-visit-fan-out
      • Update all docs/comments to avoid using "prototype" or "proto"
      • Update our dashboard code to reflect the new deployment names (none of our dashboards use "prototype" in the UI)

      I also propose that all these changes be done without a formal deprecation period, though we will probably have services running under both new and old names until the transition is complete.

      One question that came up in the team's internal discussion was whether the prefix prompt- is sufficient to disambiguate Prompt Processing components, given that there are other "prompt" things (e.g., /repo/prompt and the Prompt Products DB) that are not directly related to the Prompt Processing service. In particular, is there a danger that a container named prompt-base might try to be used by somebody else because it sounds so generic?

      Attachments

        Issue Links

          Activity

            Escalating as a package/app rename, even if it technically isn't part of the Science Pipelines build.

            krzys Krzysztof Findeisen added a comment - Escalating as a package/app rename, even if it technically isn't part of the Science Pipelines build.
            ebellm Eric Bellm added a comment -

            I support this proposal. I'm personally not stressed about collisions with /repo/prompt and the PPDB; both are named that way because their contents (largely) come from Prompt Processing.

            ebellm Eric Bellm added a comment - I support this proposal. I'm personally not stressed about collisions with /repo/prompt and the PPDB; both are named that way because their contents (largely) come from Prompt Processing.

            Yes, but my point is that there are things called "prompt" that aren't managed by our team, and there may be more in the future.

            krzys Krzysztof Findeisen added a comment - Yes, but my point is that there are things called "prompt" that aren't managed by our team, and there may be more in the future.
            Parejkoj John Parejko added a comment -

            Strong +1 here.

            Parejkoj John Parejko added a comment - Strong +1 here.

            Forgot one change – the Jira prompt_prototype DM component would also need to be renamed or otherwise transferred.

            krzys Krzysztof Findeisen added a comment - Forgot one change – the Jira prompt_prototype DM component would also need to be renamed or otherwise transferred.

            Adopting as originally proposed (i.e., without a prompt-proc-* disambiguator).

            Can I ask someone with Jira privileges to rename the prompt_prototype DM component? This part can't be ticketed...

            krzys Krzysztof Findeisen added a comment - Adopting as originally proposed (i.e., without a prompt-proc-* disambiguator). Can I ask someone with Jira privileges to rename the prompt_prototype DM component? This part can't be ticketed...

            People

              krzys Krzysztof Findeisen
              krzys Krzysztof Findeisen
              Dan Speck, Eric Bellm, Hsin-Fang Chiang, Ian Sullivan, John Parejko, Kian-Tat Lim, Krzysztof Findeisen
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Planned End:

                Jenkins

                  No builds found.